[bookmark: _Hlk27485479]Introduction to GIS: Lab 7 
Spatial Analyst – Working with Rasters[footnoteRef:1] [1:  University of Massachusetts – Amherst, ArcGIS Pro Edition
Written by Forrest J. Bowlick, Bethany Bradley, Sophie Argetsinger, Steven Bittner, Brit Laginhas, Chloe Thompson, Connor Hughes, and many others] 


The Spatial Analyst extension to ArcGIS Pro allows you to work with raster data as opposed to vector data. 

First, you’ll go over some fundamentals of raster grids before working with rasters with the Spatial Analyst extension. Then, you’ll explore some conversion tools and calculation tools which make raster processing unique and interesting, before completing the lab production activity, which will look very familiar to those of you who completed the practical practice documents[footnoteRef:2] – but this time, in raster mode! [2:  And fans of Karl Marx] 


The data for this lab is available on Moodle as a link to a Google Drive file which contains the Lab Six documents. Please download and unzip your files onto a portable USB drive (this will make your life easier if you need to move computers). If you do not have a USB drive, please obtain one for the next lab session.

While the lab production activity is what you will turn in to Moodle for a grade, please note that practice questions throughout to test your own understanding of the concepts are usefully noted in bold. These questions are very useful for testing your capacities and will be helpful to complete the lab production as well! A separate practice answer sheet is included in with the lab zip.

This lab is divided into eight parts, which you should complete in order:

Part A: Foundational Raster Information
Objective: Absorb some fundamental concepts concerning the raster data format before analyzing and manipulating files later on.
Part B: The Basics of Working with Rasters (GRIDS)
Objective: Enable the Spatial Analyst tool and practice some raster data display.
Part C: Reclassifying a Raster
Objective: Reclassify information from one raster file into a new raster file. 
Part D: Converting a Shapefile to Raster
Objective: Take a vector shapefile and convert it into a new raster file for processing needs, fun, and profit.
Part E: Raster Calculator
Objective: Explore how to manipulate raster files exactly like what they store: numbers, which you can math.
Part F: Creating Distance Grids and Completing the Model
Objective: Consider measuring distance, but this time from a raster point of view.
Part G: Topographic Analysis
Objective: Learn to manipulate digital elevation models and take your mapping to the next level.
Part H: Lab Production, Areas at Risk of Logging: Measuring Land Cover Risk in the Adirondack Park
Objective: Using your raster skills, estimate areas at risk of illegal logging in upstate New York.

Part A: Foundational Raster Information

Summary: Read through some foundational information on how Raster data functions, to build up an understanding of the structure and organization of the data within these grids. Note there is no video walkthrough for this section.

Geospatial Technology Competency Model: 5.2.19.3, 4.1.11.2, 4.1.6.7, 2.3.5, 2.3.1

The raster data format (known as a GRID file[footnoteRef:3] in some ArcGIS nomenclature) represents spatially explicit continuous surfaces. Examples include: digital elevation models (DEMs), aerial photography, bathymetry, remotely sensed imagery, and countless others. Any given point, or “pixel” in a raster dataset has a defined value, thus they are spatially continuous. Pixels are not assigned attributes like vector files. Instead, they have a single measurable value at any given location. [3:  Which contain pixels, don’tcha know] 


Each pixel in a Grid contains a single value. This number could be an actual measured value (e.g., elevation in meters), or it could be a unique code (e.g., a numeric code of 110 could be designated to mean the pixel is silty loam). Non-numeric cell values are also possible, so instead of 110, there could be a text string “silty loam” for a pixel.

The cell size is an important piece of information about any raster grid. Cell size tells you how much land area a single pixel represents. For example, a 30 m pixel represents the assigned value within a 30 m x 30 m (900 m2) area.

Like vector data, raster grids can be queried and overlaid with other raster or vector layers to analyze their spatial relationships. However, since the “attribute” is a numeric value, the analysis commands involve mathematical statements that can be very simple (e.g., elevation > 20) to more complex depending on the application.

Raster grids are typically either discrete or continuous. Discrete grids have a limited number of values and are usually derived from other spatial data. For example, habitat quality could be represented as a discrete grid (1 = high, 2 = medium, 3 = low). Continuous grids contain data that could (theoretically) have infinite values. For example, topography on Earth could be represented as a continuous grid from 0 (sea level) to 29,000 ft (Everest). You can always reclassify a continuous grid to create a discrete grid (e.g., elevations less than 1000 ft = 1, elevations greater than 1000 ft = 0 would define all low elevation areas as 1). However, once a grid is made discrete, you can never go back again to the original data.

Pixel values (in either discrete or continuous grids) can range from simple binary to complex text strings. The more complex your data values, the more memory the file will take to store and process. 
	More memory intensive

	Data Format
	Example Values
	Use

	
	Binary
	0, 1
	Represents true/false; discrete classes

	
	Integer
	1, 2, 3, 4, 178
	Could be discrete (classes) or continuous (values)

	
	Float
	2.9, 3.14, 1111.111
	Usually continuous values

	
	Text
	Flat, steep
	Represents categories; discrete classes



Raster data are easy to manipulate and read as they have specific encoding types which reveal how the data ‘looks’ within the grid. For example, with a run-length encoding, you could look at the raw raster data as it would just be stored as numbers in the order they appear in the grid: a neat organizational structure which is simple and effective. 

[image: Image result for raster data encoding][footnoteRef:4] [4:  Run length encoding example from Penn State, https://www.e-education.psu.edu/geog486/node/1879 ] 


Part B: The Basics of Working with Rasters (GRIDS)

Summary: Check that the necessary extension (Spatial Analyst) is enabled for doing Raster work, and start practicing working with Raster data.

GTCM: 5.2.19.3, 4.1.11.2, 4.1.6.7, 4.1.5, 2.3.5, 2.3.1, 2.4.2.2

Link to Video Walkthrough

1. The analytical tools we’ll be working with this lab are part of the Spatial Analyst extension, which must be enabled in your user account. ArcGIS Pro requires that an administrator of an organization assign software licenses and extensions. 

2. To check if Spatial Analyst has been licensed, open ArcPro and go to the Project tab, then Licensing. Under Esri Extensions, scroll down to Spatial Analyst and make sure it reads ‘Yes’ under the Licensed column.[footnoteRef:5] [5:  For installs in the computer labs on campus, this should be the default. For virtual installations, use the workflow in step 5 here: https://gis.library.umass.edu/toolbox/desktop/virtual-desktop/ ] 

	[image: Table
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3. From your lab 6 directory[footnoteRef:6], add the dem250k file to your Project. [6:  We provide both a tiff and a grid file depending on your preference. Both will work on a local installation. Only the tiff will work on a virtual installation.] 


4. Zoom in to a small enough area so that you can see that the grid is comprised of individual pixels. 

5. Click on a single pixel. The attribute Pixel value contains the measured value within that pixel. In this case, it represents elevation in meters. 

6. Practice your raster identification: Is this grid continuous or discrete? What is the data format (binary, integer, floating point, text)?

7. Right click on the file in the Contents pane. Notice that the Attribute Table is grayed out. Continuous raster files do not have attribute tables.
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8. Investigate the layer properties for the grid, then open its Symbology pane. 

9. The default color scheme is stretched grayscale. Change the color ramp to something else to make it more colorful.

10. Change the primary symbology to Classify instead of Stretch. The default number of classes is 5, but you can select any number of classes from 1 to 32 from the drop-down menu. You can change the class ranges by double clicking in the Upper value column in the Classes tab. [footnoteRef:7] [7:  Be careful how you set up your classes! If your classes ignore parts of your data (500-600 instead of 0-500, 500-600, 600-above), processing tools will not work properly. ] 


[image: Graphical user interface, application
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11. Try changing the classification method to ‘Quantile.’ Although the raster grid is continuous, you have now displayed it as if it were 5 discrete elevation bands.[footnoteRef:8] [8:  This is not permanent. You could redisplay it at anytime – we’ll check out how to reclassify something permanently in the next step.] 


12. Practice Display: An ecologist is interested in visualizing habitat for the Pine Marten in the Adirondacks. She thinks this animal prefers elevations between 500-600 m. Change the classified color scheme to emphasize this elevation range.[footnoteRef:9]  [9:  This question is trickier than it appears. How many classification ‘lines’ do we need to set? How many different ‘bins’ of classification are involved in setting this scheme up?] 


a. Note: Manual Interval is an option under Method. Also, you can choose a color manually for each class by double clicking on the color under the Classes tab. 

13. Before we leave layer properties, let’s get some more information on this grid. Open the layer properties for this raster. In the Source tab, you’ll find some important information about this grid. For example, under Raster Information you can see the columns and rows in the grid (2446 pixels x 3066 pixels), as well as the pixel size (67.37). If you scroll down, you can see some statistics (under Statistics), and the projection of the grid and the unit of measurement (under Spatial Reference).
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14.  Practice: What is the unit of the pixel size? How much area does one of these pixels cover?

Part C: Reclassifying a Raster

Summary: Take the symbology adjustment skills to the next level and make a new copy of your raster with values reclassified for use in models and more!

GTCM: 5.2.19.3, 4.1.11.2, 4.1.6.7, 4.1.5, 2.3.5, 2.3.1, 2.4.2.2

Link to Video Walkthrough

1. In the exercise above, we changed the color scheme of the grid to visualize potential habitat for the Pine Marten. This is useful for producing a reference map (if all we were interested in were elevation). 

2. But, if we want to have this information stored to analyze, we’d need to create a discrete classification of elevation related to habitat preference. In this case, we’ll create a new raster grid where “suitable habitat” (between 500-600 m) = 1, and “unsuitable habitat” (everything else) = 0.[footnoteRef:10] [10:  We often use this schema, of 1 = true and 0 = false, in raster modeling. This is referred to as binary modeling.] 


3. Under the Analysis tab, click on Tools and search for “Reclassify” in the Geoprocessing pane.[footnoteRef:11] [11:  Or go to Toolboxes > Spatial Analyst Tools > Reclass > Reclassify.] 
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4. Two things to notice: 

i. First, take a look at the Reclassification table. When the input raster is a layer from Contents, the default reclassification table will import the unique values or classified break values as defined by the layer symbology. You can edit the breaks by clicking on ‘Classify’ below the table, and you can edit the values by clicking directly in the Reclassification table. 

ii. Second, ensure you are saving the file where you want it to go, and name it Reclass_dem. 

5. For this example, create a grid with values of ‘1’ (representing a ‘true’ or ‘suitable’ value) for elevation ranges between 500-600 and values of ‘0’ (representing a ‘false’ or ‘unsuitable’ value) for all other elevation ranges.
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6. Click Run. The new raster grid will be added as a new layer to your map. Click around the grid, and notice that all the values are either 1 or 0 (as you defined in the reclassify tool). Now that you have a discrete grid rather than a continuous grid, you can open the attribute table. 

7. Practice: How many pixels are between 500-600m? Now that you know both the number of pixels and the pixel size, what is the total land area between 500-600m? Do you think ArcGIS could calculate this for us?[footnoteRef:12] [12:  Keep thinking on that last one] 



Part D: Converting a Shapefile to Raster

Summary: Data conversion returns as you convert a shapefile into a raster to align your data – and your analysis.

GTCM: 5.2.19.3, 4.1.11.2, 4.1.6.7, 4.1.5, 2.3.5, 2.3.1, 2.4.2.2

Link to Video Walkthrough

1. Add the layer bedrock.shp to your map. Open the attribute table and notice that the geologic units are recorded under the heading ‘Material.’ Let’s continue with our example of Pine Marten habitat. The animal prefers to forage in soils derived from Mu and MuG geologic parent material. We need to find a way to get that information from polygon (vector) to grid (raster) format so we can add it to our existing topographic analysis.

2. In Toolboxes, select Conversion Tools → To Raster → Feature to Raster.[footnoteRef:13] [13:  You can search for this too!] 


[image: A picture containing text
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3. Select ‘bedrock’ from the Input features dropdown, and ‘Material’ as the field we want to convert into a raster grid. We want the material information to form the basis of our new raster. Name the output raster “bedrock1” in your lab6 folder.

4. BEFORE YOU CLICK RUN, notice that the output cell size is weird.[footnoteRef:14] Any time you are working with raster grids, it is a good idea to make sure they’re all the same cell size and extents.[footnoteRef:15] In this case, you want your new bedrock grid to match dem250k so that the two grids are comparable for our habitat analysis.  [14:  From ArcHelp: ‘The default cell size is the shortest of the width or height of the extent of the input feature dataset, in the output spatial reference, divided by 250’]  [15:  This helps with processing and consistencies in model outputs.] 
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5. It might be tough to remember specific cell sizes or transcribe them accurately when we have a long decimal. So, we can standardize the cell size computationally.[footnoteRef:16] Click the Environments tab in the Feature to Raster pane.[footnoteRef:17]  [16:  Make ArcGIS do the work!]  [17:  We can use this in all tools or set the entire document to certain environmental conditions.] 


6. For Extent choose “Same as layer: dem250k.” For cell size choose “same as layer dem250k.” Leave the cell size projection method as ‘convert units’. For Snap Raster choose “dem250k.”[footnoteRef:18] These files are already in the same projection, so we’re good there. [18:  Extent sets the boundaries of where these tools will actually ‘do’ processing. Snap Raster ensures the resulting process matches the orientation, size, and shape of the feature of interest.] 
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Description automatically generated][footnoteRef:19] [19:  “Wait”, you say. “Why does extent say ‘As Specified Below’”? When we choose the ‘same as (layer), if fills in this extent bounding box for us automatically. Thus, specifying it.] 


7. Now, the output will be exactly the same pixel size and extent as dem250k. Click Run.

8. ‘bedrock1’[footnoteRef:20] will appear on your map and in Contents, and the default symbology will be a set of numbers. Open the attribute table to figure out what these numbers are – they correspond to Material, but grouping them 1-7, 8-14 etc. doesn’t make much sense here. Instead, what we want to display is each geological unit uniquely based on parent material. Do this in the Symbology pane by choosing ‘unique values’ and changing the value field to ‘Material.’[footnoteRef:21] [20:  This is what you named your output raster, remember?]  [21:  Screenshot next page ] 
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Part E: Raster Calculator

Summary: Explore the raster calculator, which takes advantage of the structure of the data embedded in a raster (numbers, arranged in a grid) to perform mathematical functions.

GTCM: 5.2.19.3, 4.1.11.2, 4.1.6.7, 4.1.5, 2.3.5, 2.3.1, 2.4.2.2

Link to Video Walkthrough

1. Back to our original goal:[footnoteRef:22] to classify Mu and MuG parent material as suitable habitat. There are multiple ways to do this through spatial analyst. The first you’ve learned already. You could use the Reclassify tool to set every material to ‘0’ except for Mu and MuG. A more useful computational tool that you will learn to love[footnoteRef:23] in spatial analyst is Raster Calculator. [22:  With raster processing, it is very important to keep your processing goals in mind. Otherwise you’ll have no idea what’s going on!]  [23:  Ha] 


2. Open the attribute table for bedrock1 and notice that the grid has assigned a value for all of the parent materials, and the values for Mu and MuG are 6 and 13. Those values are important to notice because raster calculator doesn’t deal with text.[footnoteRef:24] [24:  It is hard to math with letters] 


3. Open raster calculator via Toolboxes > Spatial Analyst Tools > Map Algebra > Raster Calculator. 
[image: Graphical user interface, application
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4. Our aim is to create a grid where 1 = true and 0 = false. 1 (true) should be assigned to any pixel with the Value of 6 OR 13. In Raster calculator, this statement is written as:

(bedrock1’== 6)[footnoteRef:25] | (‘bedrock1 == 13)[footnoteRef:26]  [25:  Typos intentional – do not copy and paste! The correct format and syntax is in the screenshot.]  [26:  Yes, that’s the double equals sign.] 


5. Let’s break this equation down. We have the name of the raster – bedrock1. That’s the file we’re working with. 

6. We use the double equals sign to check for an equivalency. In Python, the equals sign assigns a variable a value, and the double equals checks if something is equivalent.

7. So in this case, we’re saying ‘If value in file is equivalent to six’… for the first part of the equation.

8. Our good friend the bar is next. No, not that bar. The bar | ! The bar is a representation of the statement ‘or’. 

9. The parentheticals are keeping our statements clear and separate. Syntactically, we want to be very clear[footnoteRef:27] what we’re asking in this statement. [27:  Where have you heard ‘be clear about GIS’ before hmm…] 


10. The last part is the other value we’re interested in. So the whole statement reads:

a. If value in file is equivalent to six or if value in file is equivalent to 13: Output True.

b. Raster calculator is just that – a calculator – it outputs math and truth!

11. Remember, it’s usually better to click the operators rather than type them yourself – ArcGIS Pro doesn’t deal kindly with typos. 
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12. Raster calculator will output a calculation, which has values ‘6’ and ‘13’ = 1 and all other values = 0.[footnoteRef:28] Notice that the names of the parent material have been lost from the attribute table. If you wanted to preserve this information, you’d have to add them back in manually in a new field.[footnoteRef:29] [28:  The double equals sign did this.]  [29:  A raster calculator downside.] 


13. You can think of Raster Calculator as something of a truth box. You’re asking it to do some analysis and output values according to the math involved or based on assessing the values within the raster as true or false. 

14. Now, let’s use Raster Calculator to recreate your classification of areas between 500-600m elevation. Recall that previously we did this using reclassify. Both approaches will produce the same result. Open Raster Calculator and use the buttons to input or type in the following expression:
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15. Make sure the Output raster is where you want it to be, and name this file suitable_elev. 

16. This expression tells ArcGIS that we want it to produce a grid that is “true” (value = 1) where dem250k is less than 600 AND dem250k is greater than 500. All other values will be assigned “false” (value=0). Click Run to execute the command. Now, you’ve recreated the classification of elevations between 500-600. This should be exactly the same as the grid you created previously using reclassify.

17. Raster Calculator is NOT just for reclassifying or True False calculations. In fact, you can do any math operations inside of raster calculator!

18. If you run into trouble with raster calculator expressions, [footnoteRef:30] click on the blue question mark in the Raster Calculator pane to bring up the help page (see below). If you scroll through, you’ll get some useful information![footnoteRef:31]  [30:  Trouble is raster calculator’s middle name, after all!]  [31:  Most of these help pages are useful but fairly dense, but this one is really nice with example illustrations and such.] 
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19. For example, here’s some info on those weird operator buttons[footnoteRef:32] and what they actually mean.  [32:  ==, really?] 
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20. Click on the | (Boolean or) symbol to get more information about what | means in raster calculator:[footnoteRef:33]  [33:  Yes, that’s a symbol. Shift + \. |. Never thought you’d use that key, eh?] 
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21. Now click on the & (Boolean and) symbol to get more information about what & means in raster calculator:

[image: Graphical user interface, application
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22. Compare these two images to see how the | (OR) operation differs from the & (AND) operation. In the | (OR) illustration, you can see that if there is a value in InRas1 or InRas2 the output is a 1, and the rest are 0. In the & (AND) illustration, you see there needs to be a value in InRas1 and InRas2 for the output to be 1, otherwise the output is 0. Notice also that all NoData values stay as NoData in the output regardless of the operation you perform.[footnoteRef:34]
 [34:  No data and 0 are different, remember?] 

Part F: Creating Distance Grids and Completing the Model

Summary: Finish off your raster modeling by creating a distance grid – raster style – and combining everything together in the end with raster calculator.

GTCM: 5.2.19.3, 4.1.11.2, 4.1.6.7, 4.1.5, 2.3.5, 2.3.1, 2.4.2.2

Link to Video Walkthrough

1. One final thing that’s important for Pine Marten[footnoteRef:35] habitat is being far away from cars, and therefore far away from roads. The safest habitat occurs greater than 1 km (1000 m) from a road, while areas less than 1 km from a road are dangerous and therefore poor habitat.  [35:  Remember the Pine Marten? This is a song about Pine Marten.] 


2. Add the line shapefile roads.shp to your Project. 

3. Your initial instinct might be to do a buffer. And if we were in vector world, that’d be correct! But the model we’re building needs raster data, so let’s stay in Raster mode and try a distance calculation method that stays in that format: Euclidean Distance. 

4. Under Spatial Analyst tools select Distance > Legacy > Euclidean Distance. Select roads under Input raster and save to your lab6 folder. BEFORE YOU CLICK RUN, make sure that your environments are set to be the same extents and cell size as dem250k.[footnoteRef:36] [36:  Remind yourself of this process on page 13/14.] 
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5. Click Run to create a new continuous grid of distance to any road. Just like dem250k, you can’t view the attribute table because there are too many values for ArcGIS to calculate.[footnoteRef:37] [37:  Or display, really.] 


6. Use either the reclassify tool or raster calculator to reclassify all lands greater than 1 km from roads as “1” (meaning best habitat), and lands less than 1 km from roads as “0” (meaning poor habitat).

7. Practice: Use the OTHER tool you didn’t use above and compare the results. Are they the same?[footnoteRef:38]  [38:  They should be!] 


8. Now you have three layers of Pine Marten habitat suitability: Suitable soils (1 = yes), Suitable elevation (1 = yes), and suitable distance from roads[footnoteRef:39] (1 = yes). You want to combine these layers to create a single grid of habitat suitability.  [39:  These names relate to the files you’ve been making. Do you know what the files you have represent?] 


9. You’ve just run into a research question. Does the Pine Marten require all three of those suitability criteria to be met? Or, is it okay for the Pine Marten if any of those conditions are met (e.g., either 500-600 m OR Mu/MuG bedrock AND suitable distance from roads?). 

10. Let’s start by assuming all three conditions must be met. This is known as a conditional “AND” statement.

11. In other words, we need all three characteristics – soils AND elevation AND road distance to be TRUE (1) for the area to be a good Pine Marten habitat.

12. We could label these each alphabetically or with variables A, B, C. Therefore A & B & C identifies areas where all three overlap, or can be considered ‘true’ (that is, they have a value of 1). 

13. Open Raster Calculator and click to create the following statement: “Suitable distance from roads” & “Suitable elevation” & “Suitable soils.”[footnoteRef:40] [40:  In non-Raster calculator language, we are asking Arc to create a file that shows us where all of the conditions are true given our file inputs.] 


14. Your map[footnoteRef:41] should look something like this:[footnoteRef:42]  [41:  I removed the basemap for ease of viewing here.]  [42:  Seattle Seahawks-reminiscent color scheme notwithstanding.] 


[image: ]

15. There are a total of 246091 pixels on suitable soils, within the suitable elevation range, and more than 1 km from a road.

16. Now, let’s assume that we want to define suitable habitat as land that must be greater than 1 km from a road, but can be either on suitable soils OR within the suitable elevation range. 

17. Now use raster calculator to identify areas that are suitable distance to road and either suitable soils or suitable elevation range. In raster calculator, you have to be careful with the expression and where you put parentheses. Here’s that expression: “Suitable distance to roads” & (“Suitable elevation” | “Suitable soils”) 

18. Using this definition of suitable habitat for the Pine Marten, we get a much larger land area.[footnoteRef:43] There are a total of 1385588 pixels that are more than 1 km from a road and on either suitable soil or at suitable elevation. How you select your criteria for modeling suitability really affects your end result.  [43:  And the Green Bay Packers colors, apparently.] 


[image: ]

19. We’ve now got a model result that we like. But, the calculation is probably saved in a temporary file or named something inscrutable like raster8. To rename the grid and save it in your lab6 folder, export a copy by right clicking the file and selecting Data > Export Data. Navigate to your folder for the save location, and make sure the output format matches what you’ve been using – either TIF or GRID.
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A Brief Aside on Environments

1. In the exercises above, you had to twice set the Environments tab in raster calculator so that all your output grids were the same pixel size and extent. That’s okay if you do it once or twice. But, if you’re doing a lot of raster processing, repeating that step is annoying and can introduce error. 

2. Fortunately, you can save Environments for the whole Project, so every time you open that document and do some raster processing the output grids will be the same. 

3. Go to the Analysis tab and click Environments in the Geoprocessing group. This window looks different than what was in the raster calculator, and there are a lot more options. Set the Extent and Snap Raster as you did before.
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4. Open Raster Calculator and notice that now the environments are set to what you specified for the Project. 

5. As you might expect, you can tune any and all of these environments as you like throughout your processing. Customize, customize, customize!

Part G: Topographic Analysis

Summary: Changing gears a little, explore how to use some of the topographic analysis tools to work with Digital Elevation Models.

GTCM: 5.2.19.3, 4.1.11.2, 4.1.6.7, 4.1.5, 2.3.5, 2.3.1, 2.4.2.2

Link to Video Walkthrough

1. Topographic data (known as digital elevation models (DEMs) or digital terrain models (DTMs)) are one of the most common forms of raster grid that you’ll run into. ArcGIS has a couple of special processing tools specific to topographic data.

2. Insert a new map into your Project and add in dem250k.

3. In Toolboxes > Spatial Analyst Tools > Surface, you’ll see a number of options directed specifically at DEMs:
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4. Aspect: creates a new grid of aspect (direction of slope where 0 = N, 90 = E, 180 = S, 270 = W) based on the topographic grid.[footnoteRef:44] [44:  The coolest looking product out there.] 


5. Contour: creates a line shapefile of contours based on the topographic grid at intervals that you specify. 

6. Slope: creates a new grid of slope (in either degree or percent) based on the topographic grid.

7. Hillshade: creates a ‘3D’ type visualization of topographic depth based on a sun direction and angle that you specify.[footnoteRef:45] [45:  Great for visualizations.] 


8. Viewshed: This requires a point shapefile to represent ‘where you’re standing’ and creates a new grid of where you can see from that point location. 

9. Create a hillshade grid of dem250k using the default values. Your output file should look like a shaded relief map. Now for our next visualization trick, move the hillshade below dem250k and turn both layers on. 

a. Click dem250k in Contents to make it active. At the very top of the document, find the Raster Layer tab (highlighted in peach) and click on Appearance. Use the Transparency slider [image: Transparency Slider]to change the transparency to 50%. Check out your new map of elevation with shaded relief. For an even fancier display, change dem250k symbology to a color (rather than grayscale) color ramp.
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Part H, Lab Production: Areas at Risk of Tree Loss
Measuring Land Cover Risk in the Adirondack Park

Link to Video Walkthrough

Problem Statement: The Adirondack Park Agency is concerned about some cases of small-scale illegal ‘logging’ within the park. Park managers think that local landowners have been cutting down trees for firewood. The Adirondack Park Agency has asked for your help to identify locations likely to be targeted this summer so that they can position law enforcement to prevent loss of trees. Here are the criteria that the park managers believe create elevated risk for illegal tree cutting:

1) Sites within 300 m of roads are at high risk
2) Sites with slopes less than 10 degrees are at high risk
3) Sites with hardwood trees (land cover value = 1) are at high risk, and sites with mixed, but predominantly hardwood trees (land cover value = 2) are at moderate risk
4) The Park Agency is only interested in lands within park boundaries[footnoteRef:46] [46:  Ah, wouldn’t it be great if there were some kind of Clip tool we could use with raster data…it’d need to be called something really simple. Like ‘clip raster’.] 

5) Also, the Park Agency would like the final map in the same spatial extents, pixel resolution, and snap raster as dem250k[footnoteRef:47], for consistency. [47:  See part D.] 


Use the files in the Lab 6 folder to identify high composite risk (meets all the high-risk criteria and within park boundaries), and moderate composite risk (meets high risk criteria for roads and slopes, moderate risk criteria land cover, and within park boundaries). 

Map to be Turned in: 
1) Create a map for the Adirondack Park Agency highlighting areas at high and moderate risk. For visualization, make low risk areas no color and overlay the map on a shaded relief background. Also include the outlines of the towns that overlap the park so the managers can figure out jurisdiction. Include a legend, scale bar, and title on your map.[footnoteRef:48] [48:  You’re not getting off that easy, more stuff on the next page.] 


Questions to be Turned in:
1) Create a bullet-point list of the data layers that you need to complete the risk analysis.
2) What is the pixel size for the DEM raster?
3) What is the pixel size for the landcover raster?
4) How many pixels (within the park boundaries) meet the road distance high risk criterion?
5) How many pixels (within the park boundaries) meet the slope high risk criterion?
6) How many pixels (within the park boundaries and in the resolution of the dem250k raster) meet the landcover high risk criterion?
7) How many pixels (within the park boundaries, and in the resolution of the dem250k raster) meet the landcover moderate risk criterion? 
8) How many composite high-risk pixels are within the park boundaries?
9) What is the total land area, in square kilometers, of the composite high risk within the park boundaries?
10) How many composite moderate risk pixels are within the park boundaries?
11) Describe how you can calculate the area covered by the moderate risk pixels.
12) What is the total land area, in square kilometers, of the composite moderate risk within the park boundaries?
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